Seite 1 von 2

Header jetzt auch im Forum

Verfasst: Dienstag 1. Februar 2011, 11:31
von Berlinspotter
Ihr werdet es heute sicher bemerkt haben: Die Titelleiste (Header) sitzt nun auch über dem Forumsbereich. Der Grund: ich wurde angezählt, da bei einem direkten Forumszugriff (ohne über die Titelseite zu gehen) kein Impressum mehr auffindbar war.

Bevor ich mich jetzt mit der Abmahnmafia anlege, habe ich mich nun gestern nacht noch hingesetzt und das irgendwie mit meinen bescheidenen Kenntnissen reingefrickelt. Die Ladezeit verlängert sich um 0,3 Sekunden. Ich bitte um Nachsicht.

PS: Wieso ist dass denn unter Chrome nicht sichtbar? Da fehlt ein Feld - genau das Impressum. Ich werde irre.

Re: Header jetzt auch im Forum

Verfasst: Dienstag 1. Februar 2011, 11:52
von Jörg
Das mit diesen Abmahnungen ist zum K*****.

Oliver (Berlinspotter) hat geschrieben:PS: Wieso ist dass denn unter Chrome nicht sichtbar? Da fehlt ein Feld - genau das Impressum. Ich werde irre.


In der letzten Zelle fehlt eine schließende Klammer:

<td rowspan="0" height="20"><A HREF="../kontakt.htm">

Schreibe am besten auch das a href klein.

Verfasst: Dienstag 1. Februar 2011, 12:00
von Berlinspotter
Vielen Dank. Werde ich dann heute abend korrigieren.

Verfasst: Dienstag 1. Februar 2011, 12:48
von BER-Spotter
Unter Opera sehe ich das auch nicht...

Verfasst: Dienstag 1. Februar 2011, 13:30
von Dirk
BER-Spotter hat geschrieben:Unter Opera sehe ich das auch nicht...

Ab heute Abend...

Verfasst: Dienstag 1. Februar 2011, 14:52
von EDGE-Henning
Aber auf alten Bildschirmen passt der Header und die Links nicht, das Bild wirkt so zerissen.
Bei Zeit würde ich Dir empfehlen, auf die phpbb3 Version umzurüsten.
Und dann den Header in einem Hex-Editor anzupassen oder auch sogar in MS-Frontpage.

Ich hatte die gleichen Probleme, deshalb mein Hinweis.

Verfasst: Dienstag 1. Februar 2011, 16:20
von borchi
Das schließen des href tags sollte reichen, da einige Browser die nicht "flexibel" von alleine schließen. Vielleicht noch einen Zeilenumbruch zwischen die beiden, jetzt nebeneinander dargestellten Tabellen machen, damit der Header über der Forennavigation steht?

@Henning, was für einen Auflösung und was für einen Browser benutzt du?


Zum testen von Webseiten kann ich Browsershoots.org empfehlen:

http://browsershots.org/http://www.berlin-spotter.de/phpBB2/index.php

Verfasst: Dienstag 1. Februar 2011, 18:15
von EDGE-Henning
Ich nehme:
IE-8,
Google Chrome,
Firefox,
Alle jeweils in der aktuellsten Version.

Verfasst: Dienstag 1. Februar 2011, 18:32
von Berlinspotter
EDGE-Henning hat geschrieben:Aber auf alten Bildschirmen passt der Header und die Links nicht, das Bild wirkt so zerissen.


Das war gestern Abend erstmal nur die Schnell-Lösung. Mache ich dann.

Verfasst: Mittwoch 2. Februar 2011, 11:45
von borchi
Die Variante zentriert wäre dann diese:

<td class="bodyline"><table width="100%" cellspacing="0" cellpadding="0" border="0">
<tbody><tr>

<!--Header-->

</tr></tbody></table>

<table cellspacing="0" cellpadding="0" border="0" align="center"> <!--center einfügen-->

<tbody><tr>
<td height="20" rowspan="1"><a href="../airlines/airlineauswahl.htm"><img width="200" height="20" border="0" alt="Airline-Stories" src="../airlineportraits.jpg"></a></td>

<td height="22" rowspan="1"><a href="../index.htm"><img width="379" height="22" border="0" alt="Home" src="../regenstart1.jpg"></a></td>

<td height="20" rowspan="1"><a href="../unfall/unfall2007/berichteaug.htm"><img width="200" height="20" border="0" alt="Flugzeugunglücke ab 2000" src="../unfallberichte.jpg"> <a></td></tr>

<tr>
<td height="20" rowspan="1"><a href="news.htm"><img width="200" height="20" border="0" alt="Airline-News worldwide" src="../airlinenews.jpg"></a></td>

<td height="22" rowspan="1"><a href="../index.htm"><img width="379" height="22" border="0" alt="Home" src="../regenstart2.gif"></a></td>

<td height="20" rowspan="1"><a href="../phpBB2/index.php"><img width="200" height="20" border="0" alt="Diskussionsforum für alle" src="../forum.jpg"></a></td></tr>


<tr>
<td height="20" rowspan="1"><a href="../focusauswahl.htm"><img width="200" height="20" border="0" alt="Pics from TXL, SXF and THF" src="../fotoarchiv.jpg"></a></td>

<td height="22" rowspan="1"><a target="main" href="../index.htm"><img width="379" height="22" border="0" alt="Home" src="../regenstart3.gif"></a></td>

<td height="20" rowspan="1"><a href="../link.htm"><img width="200" height="20" border="0" alt="Links" src="../links.jpg"></a></td></tr>

<tr>
<td height="20" rowspan="1"><a href="../spotternewsauswahl.htm"><img width="200" height="20" border="0" alt="News from SXF, TXL, THF, Spotterplaces, Visitors" src="../spotterecke.jpg"></a></td>

<td height="22" rowspan="1"><a href="../index.htm"><img width="379" height="22" border="0" alt="Home" src="../regenstart4.gif"></a></td>


<td height="20" rowspan="1"><a href="../kontakt.htm"><img width="200" height="20" border="0" alt="Kontakt - Impressum" src="../kontakt.jpg"></a></td></tr>

</tbody></table>



<table cellspacing="0" cellpadding="2" border="0" align="center"> <!--center einfügen-->
<br> <!--zeilenumbruch einfügen-->



<tbody><tr>


<td valign="top" nowrap="nowrap" align="center"><span class="mainmenu">&nbsp;<a class="mainmenu" href="faq.php"><img width="12" hspace="3" height="13" border="0" alt="FAQ" src="templates/subSilver/images/icon_mini_faq.gif">FAQ</a></span><span class="mainmenu">&nbsp; &nbsp;<a class="mainmenu" href="search.php"><img width="12" hspace="3" height="13" border="0" alt="Suchen" src="templates/subSilver/images/icon_mini_search.gif">Suchen</a>&nbsp; &nbsp;<a class="mainmenu" href="memberlist.php"><img width="12" hspace="3" height="13" border="0" alt="Mitgliederliste" src="templates/subSilver/images/icon_mini_members.gif">Mitgliederliste</a>&nbsp; &nbsp;<a class="mainmenu" href="groupcp.php"><img width="12" hspace="3" height="13" border="0" alt="Benutzergruppen" src="templates/subSilver/images/icon_mini_groups.gif">Benutzergruppen</a>&nbsp;
</span></td>
</tr>
<tr>
<td valign="top" nowrap="nowrap" height="25" align="center"><span class="mainmenu">&nbsp;<a class="mainmenu" href="profile.php?mode=editprofile"><img width="12" hspace="3" height="13" border="0" alt="Profil" src="templates/subSilver/images/icon_mini_profile.gif">Profil</a>&nbsp; &nbsp;<a class="mainmenu" href="privmsg.php?folder=inbox"><img width="12" hspace="3" height="13" border="0" alt="Du hast keine neuen Nachrichten" src="templates/subSilver/images/icon_mini_message.gif">Du hast keine neuen Nachrichten</a>&nbsp; &nbsp;<a class="mainmenu" href="login.php?logout=true&amp;sid=b57698a9195ffb8709300592fb7bbe23"><img width="12" hspace="3" height="13" border="0" alt="Logout [ borchi ]" src="templates/subSilver/images/icon_mini_login.gif">Logout [ borchi ]</a>&nbsp;</span></td>
</tr>
</tbody></table></td>

Verfasst: Mittwoch 2. Februar 2011, 16:31
von Berlinspotter
Alles klar - danke. Ich hatte gestern echt seltsam zerschossene Varianten. War froh, es wenigstens so hingekriegt zu haben.

@Jörg: da fehlte keine Klammer. Der Befehl geht in der nächsten Zeile weiter. Ich werde mal die Plätze tauschen. Unfälle werden ja seit mehreren Jahren nicht mehr geführt.[/quote]

Verfasst: Mittwoch 2. Februar 2011, 16:56
von borchi
Mach vorher eine Kopie von der Datei :)

Verfasst: Donnerstag 3. Februar 2011, 08:32
von Spotterlempio
jetzt sieht es wieder ordentlich aus, alles schön mittig :D

Verfasst: Donnerstag 3. Februar 2011, 08:46
von Jörg
Oliver (Berlinspotter) hat geschrieben:@Jörg: da fehlte keine Klammer. Der Befehl geht in der nächsten Zeile weiter.


Seltsam - ich hatte es mir in der Quelltextansicht des FF anzeigen lassen. Da stand alles in einer Zeile und die Klammer fehlte.

Logout borchi...

Verfasst: Donnerstag 3. Februar 2011, 08:58
von Proud of Freddie
...ist im Header gleich mit kopiert worden, daher ist das Login oben blockiert, es geht aber noch unten unter den Rubriken.
Gruss Bernte